La versión de mantenimiento de WordPress 6.4.1 corrige errores de la versión 6.4

La versión de mantenimiento de WordPress 6.4.1 corrige errores de la versión 6.4

WordPress lanzó una versión de mantenimiento el miércoles por la noche para abordar los problemas descubiertos poco después de que WordPress 6.4 fuera lanzado al público el martes 7 de noviembre.

Dos de los problemas eran bastante graves porque afectaban el funcionamiento de algunos complementos y podían causar problemas a los sitios que experimentaban cualquiera de los problemas.

El tercero fue un error tipográfico que resultó en una notificación mal configurada en el panel de administración.

Tres problemas resueltos

  1. Error de tipografía
  2. El código eliminado causó problemas de compatibilidad con versiones anteriores
  3. Un error crítico hace que la descarga falle

Error tipográfico en el código: problema estético menor

El problema del error tipográfico fue relativamente menor. Esto afectó la forma en que aparecía una pantalla de recordatorio en el panel de administración, lo que provocó que se extendiera a la parte superior de la página.

Antes de la solución:

Después de la solución:

La versión de mantenimiento de WordPress 6.4.1 corrige errores de la versión 6.4

a

Error de compatibilidad con versiones anteriores

Este error fue una de esas cosas aleatorias que no siempre se pueden explicar.

Lo que sucedió fue que los contribuyentes principales eliminaron el código que el núcleo de WordPress ya no usaba, por lo que se suponía que era seguro eliminarlo.

Pero… los complementos todavía usaban este código y, como ahora faltaba, aparentemente WP 6.4 estaba causando que estos complementos fallaran.

Por tanto, la solución contenida en esta versión de mantenimiento consiste en añadirla.

Error crítico que causa un error de cURL

La última solución solucionó un error que provocaba que las actualizaciones no se descargaran y mostrara un mensaje de error que indicaba que el tiempo de espera había expirado, error de cURL 28: Se agotó el tiempo de espera de la operación.

READ  Arrojando luz sobre la fotónica cuántica

De acuerdo a discusión interna de WordPress Cómo resolver este problema :

“Esta pregunta debería ser crucial.

6.4 actualizó la versión de la biblioteca de Solicitudes que incluyó un cambio importante para cualquiera que ejecute en un host con la versión curl 7.29 (al menos).

Este problema también fue otro de esos problemas aleatorios. En este caso, se trataba de servidores que utilizaban una versión antigua y desactualizada de la biblioteca cURL (cURL 7.29). La última versión de cURL es 8.4.0.

Llevar

WordPress lanza versiones de prueba de WordPress para que la comunidad pruebe e informe cualquier error.

Pero si nadie los experimenta, aparecen cuando se lanza la versión final y eso es lo que pasó.

La versión original de WordPress 6.4 actualizada por esta nueva versión de mantenimiento recibió el nombre en código Shirley. La nueva versión de mantenimiento solicita un nombre en clave No me llames Shirley.

Imagen destacada de Shutterstock/photosince

Deja una respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *